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1. Installing Profile Builder
After downloading Profile Builder, you should have a ZIP file named ‘ProfileBuilder.zip’.

1) Unzip the contents of ‘ProfileBuilder.zip’ using an application such as WinZip.  Take note of where the 
unzipped files are now located.

2) After unzipping, you should have a file called ‘pb_loader.rb’ and a folder called ‘ProfileBuilder’.   Copy both 
the file and the folder to your SketchUp plugins directory (see steps 3 and 4)

3) If you are using Windows, the path will be something like this: C:\Program Files\Google\Google SketchUp 6\
Plugins

4) If you are on a Mac, the path will be something like this:  Users/Library/Application 
Support/SketchUp7/Sketchup/Plugins.  The plugin may NOT work if installed to the following directory: 
Macintosh HD/Library/Application Support/Google Sketchup 6/SketchUp/Plugins 

5) Close SketchUp if you have it open.
6) Run SketchUp.
7) Check your ‘Plugins’ menu.  If you see the Profile Builder menu item, the installation was successful.
8) If you do not see the menu item, go to Window->Preferences->Extensions and make sure that ‘Profile 

Builder’ is checked.
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2. What is Profile Builder?
Profile Builder is a SketchUp plugin that allows you to create Profile Members quickly and accurately.  The power of 
the plugin lies in its ability to create intelligent geometry that can be changed and edited while still preserving the 
intelligence.  This is useful for all types of designers including woodworkers, engineers, architects, and interior 
designers because geometry can be quickly modified as the design progresses or to experiment with alternative 
design options without having to remodel the geometry.  The two core 
concepts of Profile Builder are Profiles and Profile Members.

3. What is a Profile?
A Profile is simply a two-dimensional shape that forms the cross-section 
of an object.  It can be any size and have any number of holes.  Many 
building materials are defined by their profile.  The world of design is 
filled with thousands of profiles, many of which have standard 
dimensions.  Examples of standardized profiles include dimensional 

lumber (eg. 2x4), steel wide 
flange shapes (eg. W8x18), and standard pipe (eg. 4” SCH 40). 

4. What is a Profile Member?
Profile Members are three-dimension objects that have a constant Profile 
(cross-section).  A Profile Member is defined by its Profile (shape and 
orientation) and a path.  The path can be a single line, poly-line, or curve. 
The path can also be a closed shape (eg. Circle).  Profile Members can 
represent many types of building materials such as wood studs, mouldings, 
steel beams, pipes, rebar, cladding, walls, and eaves troughs.  

5. Profile Libraries
A profile library is a file that contains profiles that you can select to build Profile Members.  Once you have at least 
one profile library, you can add custom profiles to it, remove profiles, or rename profiles.

Creating a Profile Library
To create a new profile library:
- Open the Profile Builder dialog: Plugins->Profile Builder
- Click on the Library drop-down list

4 Profile Builder Manual Rev 1



- At the bottom of the list, select the ‘Create New...’ 
option.

- Enter the name of your new library.  Type in ‘My 
Profiles’ and click ‘OK’ .

- An empty profile library will be created with the 
given name. 

Profile libraries are ASCII text files with the extension PLB.  All 
profile libraries (PLB files) are stored in the 
ProfileBuilder/Libraries (within your Plugins) folder by default.  If 
you download additional libraries, they must be copied into this 
folder.  

6. Creating Custom Profiles
New custom profiles can be created in SketchUp by following 
these steps:

- Open the Profile Builder dialog: Plugins->Profile Builder
- Select the profile library file that you want to store the profile from the ‘Library’ drop-down list.

- Select a face in SketchUp.   

Click on the ‘Add Profile’ button
- Enter the name of your new profile and click ‘OK’  
- A new profile will be saved in the currently selected library.  The 

newly created profile will become the ‘active profile’ and will now be 
selected in the ‘Profile’ drop-down list. 
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TIP: In order to ensure that the profile is saved with the correct orientation, it is recommended to create all  
profiles in the X-Y plane with the Y axis pointing up.  In other words, you should switch your view orientation to  
‘Top’ and draw the profile as if you were drawing on a piece of paper.  All of the points of the profile should be  
the same depth (i.e. have the same Z coordinate). 

In this plugin, a profile is oriented with the X axis (red) pointing right and the Y axis (green) pointing up.  It does not 
matter where in 3D space that you create a profile.  The origin (axis) of the profile will always be the bottom-left 
corner of the profile’s bounding box.
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7. Creating Profile Members
You cannot create a profile member without having at least one profile library and one saved profile.  See above for 
how to create profile libraries and profiles.  New Profile Members can be created in two ways: Defining the path ‘on 
the fly’ OR by first selecting an existing path.  Remember, a profile member is defined by a Profile and a path.  A 
path is a series of points in space.  

To create a Profile Member ‘on the fly’:

- Choose the active profile from the ‘Profile’ 
drop-down list.

- Click the ‘Build’ icon 
- Click a point in 3D space to start the member.
- Click a second point to create a linear (one 

segment) member.
- You can now choose to complete the member 

by pressing the ‘Esc’ key or you can continue 
clicking additional points to add to the path of 
the member.

To create a Profile Member by selecting an existing 
path:

- Select the active profile from the ‘Profile’ drop-down list.
- Select any number of continuous lines, edges, or curves OR select a single face.

- Click the ‘Build along path’ button.
- A Profile Member will be created along the selected path. 
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- A dialog will be displayed asking you if you want to reverse the path direction.  Click ‘yes’ to reverse the 
direction of the member or ‘no’ to accept the member direction as shown.

NOTE: When you create a Profile Member, a group of geometry is created that is automatically named the same  
as the name of the current Profile.

8. Profile Member Orientation
Profile Members are defined by a profile and path.  However, the orientation of the profile can be modified using 
the following properties: Placement Point, Rotation, Mirror, X Offset, and Y Offset.

Placement Point
Placement Point determines the X-Y position of the 
profile along the path.  There are nine options for 
placement points.  Placement Points will form the 
reference line of the profile member.

Different types of Profile Members tend to have different 
placement points depending on the shape of the profile 
and/or the way the member is used.  For example, the 
reference line of a vertical pipe or column is usually the 
center.  However, the reference line of a steel beam or 
wood joist is usually the Top-Middle.  (see image below)
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Mirror
The Mirror property is useful for unsymmetrical Profiles.  If enabled, the profile will be effectively mirrored about a 
vertical line going through the placement point. 

Offset

In addition to the Placement Point property, you can also use the offset properties to adjust the X-Y position of the 
profile along the path.  Recall that the X-axis points to the right and the Y-axis points up.  If you enter a positive 
value for X Offset, the profile will be shifted right and if you enter a positive value for Y Offset, the profile will be 
shifted up.  Negative values will shift the profile in the opposite direction.   You can enter units in the offset value 
box (eg. 15mm).  If you do not enter units, the units will default to the default SketchUp model units. 
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Rotation
The Rotation property allows you to specify the rotational orientation of the profile along the path.  The axis of 
rotation is the Z-axis which passes through the path of the Profile Member and is specified in degrees.   A positive 
angle of rotation will rotate the profile counter-clockwise while a negative angle of rotation will rotate the profile 
clockwise.   One thing to remember is that Profile Builder applies the rotation property before the offset property. 
(see image below).  The mirror attribute is applied last.

9. Smoothing Angle
The smoothing angle property allows you to soften and smooth the edges of the profile member automatically.  The 
result is identical to using the SketchUp ‘Soften Edges’ window.  The angle is specified in degrees. 
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Note: If you are using profiles with many curved edges or if you are creating a profile along a complicated curved  
path, it is recommended to change your smoothing angle to 0.0 in order to improve performance.  Then, you can  
smooth the edges manually using the SketchUp ‘Soften Edges’ tool.  

10. Editing Profile Members
The properties of any Profile Member can be edited any time after creation.  You can edit several profile members 
simultaneously.  To edit a Profile Member:

- Select at least one Profile Member.

- Click the ‘Edit member properties’ button. 
- A property selection dialog box will be displayed prompting you to choose the properties that you wish to 

edit.
- Select the properties that you wish to edit by ‘checking’ them.
- When you click ‘Apply’, the current properties in the Profile Builder dialog will be applied to the selected 

members .

11. Acquiring properties from existing Profile Members
To populate the fields of the Profile Builder dialog with the properties of an existing Profile Member:

- Select a Profile Member.  

- Click the ‘Acquire properties from selection’ button
- All of the fields except for the ‘Library’ and ‘Profile’ drop-down list will be populated with the properties of 

the selected member.  
- The active profile will be changed to the profile of the selected member and the profile preview image will 

be updated.  

IMPORTANT:  The active Profile may NOT always be the one that is displayed in the dialog drop-down list.  This  
situation occurs when acquiring properties of a selected member.  The active Profile is ALWAYS the profile that is  
displayed in the profile preview window.  The name of the active Profile (along with the height and width) can be  
viewed by holding your mouse over the profile preview window. (see image on next page)
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12. Editing Profile Member Paths
The path of a profile can be modified after creation:

- Select a Profile Member

- Click the ‘Edit member path’ button
The selected member will be hidden (make sure you have Hidden Geometry turned off in the View menu) 
and a new group will be created containing edges that represent the path of the member.  The name of the 
new group will be ‘MemberName_path’, where MemberName is the name of the Profile Member you are 
editing.  A text label will also appear prompting you to double-click the path group.

- Double-click the new group to begin editing the path.  
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- Use the standard SketchUp tools (line, arc, erase, move, etc.) to change the path of the member.
- When you are satisfied, close the group.
- When you close the group, Profile Builder will try to find a valid path from the lines that you have edited or 

created.  The path must be continuous.  Any geometry besides lines (edges) contained in the path group will 
be ignored.

- If a valid path is not found, an error message will be displayed.  To fix this problem, you must repeat the 
steps above and make sure that there is a continuous set of edges contained in the path group prior to 
closing the group.

- If a valid path is found, the path group will be deleted and the original Profile Member will be updated to 
follow the newly created path.

REMEMBER: When you are editing a path, the original Profile Member is automatically hidden, not deleted.  
When you are finished editing the path, the Profile Member will be automatically ‘unhidden’.  Try editing a Profile  
Member with the Outliner Window open to better understand how the process works.   

IMPORTANT: Do NOT click on any geometry in the Outliner while you are editing a path.  This will cause a Bug  
Splat if you try to re-select the path group you were editing.  

IMPORTANT: You cannot alter the path of a profile member by moving, rotating or scaling the path group.  You  
must make your changes inside group-edit mode.  

13. Profile Member Path Inferencing (PMPI)
Profile Member Path Inferencing is a special technique that allows you to temporarily replace Profile Members with 
their path so that you can inference to the path.  (See SketchUp documentation for more information about 
inferencing).  There are two ways to access PMPI.  You can access it via context menu (right-click) or while you are 
using the Build tool by pressing the CTRL key.

To use PMPI via context menu:

- Right click on a Profile Member to open the context menu.
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- Select ‘PMPI’.
- The member will be hidden and a new group will be created that represents the member path.
- To clear all PMPI paths and unhide the members, select ‘clear PMPI’ from the context menu.

To use PMPI with the Build tool:

- While you are using the build tool, hover your mouse over a Profile Member and press the CTRL key.
- The member will be hidden and a new group will be created that represents the member path.
- PMPI will be automatically cleared when the Build tool becomes deactivated.
- You can also clear PMPI by the context menu.
PMPI is especially useful when trying to connect members that use center placement points.  For example, in 
the sequence of images below, a pipe has been created using a center placement point.  We now want to join 
another pipe so that the center-lines of both pipes intersect.  This can be done easily by clicking the CTRL button 
while hovering your mouse over the first pipe.

TIP: In order to use PMPI with the Build tool, the keyboard ‘focus’ must currently be the SketchUp window, NOT  
the Profile Builder Dialog.  The easiest way to set the focus is to right-click on empty space in your model OR use  
the middle mouse button to orbit your model prior to initiating PMPI. 

14. Select by Member Attributes
It is possible to create a selection set based on any of the Profile Member attributes:

- First, set the properties of the Profile Builder dialog to the criteria of your desired selection.  For example, if 
you wish to select all members with a center placement point, change the current placement point to 
‘Center’.

- Click the ‘Select by member attributes’ button
- A property selection dialog box will be displayed prompting you to choose the properties of your desired 

selection set.
- Select the properties that you wish to add to your selection criteria by ‘checking’ them.
- When you click ‘Apply’, the Profile Members that match all of the selection criteria will be added to the 

selection set.

NOTE: The selection set will not be cleared prior to using this feature.  This is so you can add new  
members to an existing selection set. 
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15. Working with Profile Libraries

Installing downloaded libraries
Profile Libraries will be available for download from the Smustard website 
(www.smustard.com/script/ProfileBuilder).    All profile libraries must be in the same folder on your computer (or 
network) in order to be accessible by the plugin.  By default, profile libraries are stored in the 
ProfileBuilder/Libraries folder.  The image below shows a typical Windows installation.  Once you have copied your 
profile library file (PLB) to the correct folder, the next time you open the Profile Builder dialog, the library will be 
selectable.  

Creating a custom or network path for libraries
 If you want to be able share profile libraries across a network, or create a custom location for your profile libraries, 
you must do the following:

1) Create a text file called ‘library_path.txt’ located in your ProfileBuilder folder.
2)  The contents of this text file must be a valid path to the folder of your choice. (See image on next page). 
3) If the ‘library_path.txt’ file exists, Profile Builder will look for your PLB files in the designated folder the next 

time you start SketchUp.
4) Make sure that any new libraries you download are placed in this folder. 
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Deleting Profiles
If you wish to delete a profile from a library, simply select the profile from the Profile drop-down list and click the 

‘Delete Profile’ button.  The selected profile will be removed from the current library. 

Profile Naming rules and Renaming profiles

To rename the currently selected profile, click the ‘Rename profile’ button   The naming rules to keep in mind 
when naming a profile are:

- You cannot have any white space in the profile name.
- You cannot use the | , ‘ (single quote) or the “ (double quotes) characters in the profile name.

Illegal characters will be automatically deleted when you create or rename a Profile.

Batch Adding Profiles to a Library
It is possible to quickly build large Profile Libraries from existing SketchUp faces by ‘batch adding profiles’.  For 
example, if you had created a SketchUp model consisting of several hundred SketchUp faces, you can add them all 
to a Profile Library with one operation.  Just follow these steps:

- Select the Profile Library that you wish to add the new Profiles to from the ‘Library’ drop-down list or create 
a new Profile Library.

- Select the faces that you want to save as Profiles.  There is no limit to the number you can select. 
- Click the ‘Create new Profile’ button
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- You will be prompted to enter the name of the new Profile.  However, when you have more than one face 
selected, a new Profile will be created for each face.  The first Profile created from the selection set will be 
named whatever you input for the Profile Name.  The remaining new Profiles will be named with an 
incremental numeric suffix.  (eg. chairRail, chairRail1, chairRail2, etc.)

REMEMBER: To ensure the profiles are saved with the correct orientation, it is recommended to model the faces  
on the X-Y plane and to have the front side of the faces point up.

Adding Profiles to Favourites

You can add the current Profile to your favourites by clicking the ‘Add to Favourites Button’ Profile Builder will 
create a new Profile Library called ‘Favourties.plb’ the first time you click this button.  This will give you quick access 
to your most commonly used Profiles.

Deleting Libraries
If you wish to delete an entire Profile Library, you must delete the PLB file in your profile library folder.  You cannot 
delete a library using the Profile Builder dialog.
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16. Creating Quantity Reports
With Profile Builder, you can create a report that is useful for estimating quantities of building materials.

DISCLAIMER: Quantity Reports created with Profile Builder are for estimating purposes only and should not be  
used to determine material ‘cut lengths’.  While linear Profile Members should provide accurate quantity reports,  
curved members, or members created from multiple path segments will only produce an approximation to the  
actual material lengths and volumes.  Also, any member that has been edited inside ‘group-edit’ mode will not  
provide an accurate quantity report.

To create a quantity report:

- Go to Plugins->Profile Builder Utilities->Export Quantity Report 
- If you have no geometry selected, the report will include all Profile Members in your model (including 

hidden members)
- If you have made a selection, the report will include only the Profile Members in your selection set.
- Choose the file format from the drop down list.  You have the option of CSV (comma separated values) or 

Plain Text (fixed width ASCII).  CSV files can be opened directly by many spreadsheet applications such as 
Excel.

- You will be prompted for the name and location to save the report.
- Once you click ‘Save’, the report will be created and automatically opened. 
- The quantity report contains the following fields: Profile, Member Name, Segments, Length, and Volume
- At the end of the report is a summary of the total quantities for each type of profile.
- See image below for a sample quantity report.
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What are the Profile and Member Names?
The profile name is just the name of the profile that was used to create the member.  The member name is 
equivalent to the SketchUp group name.  You can change the member name by selecting a Profile Member, opening 
the ‘Entity Info’ (under the Window menu), and changing the group name.  When you create a new Profile Member, 
the group name is automatically set to the Profile Name.  If you later change the Profile by editing the member 
properties, the group name will not change.  For this reason, the Profile Name and the Member Name may not 
always match.

How is Length determined?
Member length is determined from the length of the path that was used to create the member.  If a group that 
contains the member has been scaled using the SketchUp scale tool, the length of the member will still be 
calculated correctly.  However, if you enter group edit mode for the Profile Member and make changes to the 
geometry (for example, by using the PushPull tool), the calculated length of the member may no longer be correct.

How is Volume determined?
Volume is determined from the product of the Profile area and the calculated length (see above).   If a group that 
contains the member has been scaled using the SketchUp scale tool, the volume of the member will still be 
calculated correctly.

How are Units and Precision 
determined?
The output units, formatting and precision are determined 
from your current units settings in SketchUp.  To change 
the units and precision:

- Open the Model info Window (Window->Model 
Info) and select Units

- The settings contained in units dialog box will be 
used to format the display of the quantity report. 

TIP: Before exporting the quantity report, set your units format to ‘Decimal’ and turn off ‘Display Units  
Format’ if you plan to open the report with spreadsheet software. (see above)
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17. Assigning Mark Numbers (Batch Naming)
Profile Builder allows you to rename several Profile Members at the same time.  You can easily assign sequential 
identification numbers using the following steps:

- Select at least one Profile Member
- Choose Plugins->Profile Builder Utilities->Assign Mark Numbers
- A dialog box will open allowing you to input the Prefix, Suffix, and 

starting mark number.
- You can input ‘$P’ for the prefix or suffix to substitute the name of 

the profile.
- You can leave the ‘Start Number’ field blank if you do not want to 

use incremental numbers in the member name.

18. Profile Members, Groups, and Components
Keep these things in mind when working with Profile Builder:

• Profile Members are Groups (not components).

• If you convert a Profile Member group to a Component, it will no longer behave as a Profile Member.

• Profile Members CAN be nested inside groups or components.

• If you assign mark numbers to Profile Members that are nested inside a component, all instances of the 
component will be assigned the same names.   
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19. Troubleshooting

I can’t see the Profile Builder menu item or toolbar.
There is most likely an installation error.  Try removing all the Profile Builder files and installing the plugin again. 
Sometimes, the subfolders get lost when certain programs unzip the zip file.  Make sure you have the file 
‘pb_loader.rb’ and the folder ‘ProfileBuilder’ in the correct location (See Part 1 Installation).  If you are on a Mac, 
make sure you install the plugin in the 'Users/Library/Application Support/SketchUp7/Sketchup/Plugins folder ' (not 
the usual Macintosh HD subfolder).

My path is a closed loop.  Why won’t my Profile Member close?
Choosing the proper placement point is very important in order to get the Profile Member to form a closed loop. 
For best results, choose a placement point that coincides with a vertex on the profile (like a corner).  Center and 
middle placement points are less likely to result in a closed Profile Member.

Sometimes, my Profile Member disappears as I am drawing it.  What is wrong?
This is known issue that seems to occur for some users running SketchUp 6.  It is not known to occur in SketchUp 7.

Why does the profile orientation twist along a three dimensional path?  I want to 
use a helical path.
This is a known issue with the ‘follow me’ function in SketchUp as well.  There is currently no solution.

I am trying to use PMPI by pressing the CTRL key but nothing is happening.
Make sure that the keyboard 'focus' is in the SketchUp editing window by orbiting your view with the middle mouse 
button or by right-clicking empty space in your model.  Also, you have to make sure that you are currently working 
in the same context as the member you are trying to use PMPI on.

I keep getting the error message 'A valid path was not found...' even though I know 
the path is valid.
The reason for this could be that there is are extremely small edges accidentally selected that you are not aware of. 
If you do a 'Window Select' to select the edges, or triple click to select all conncted edges, you may be 
unintentionally selecting some edges.  Try single-clicking each edge to select the path instead.
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